aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-20 19:59:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-20 19:59:29 +0000
commit29fd37780b9070fb3f52bdaab4560fffa679275d (patch)
treebeb269badc74203053778edeac35ccfdcb620cff /package
parent8d7ca65dab585df56a8bbb69a48d42fb63104e1c (diff)
downloadupstream-29fd37780b9070fb3f52bdaab4560fffa679275d.tar.gz
upstream-29fd37780b9070fb3f52bdaab4560fffa679275d.tar.bz2
upstream-29fd37780b9070fb3f52bdaab4560fffa679275d.zip
switch to newer CS5535 GPIO driver, patch from Philip Prindeville
SVN-Revision: 25631
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk26
1 files changed, 19 insertions, 7 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 56cda45f70..60a534c86d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -167,15 +167,9 @@ define KernelPackage/gpio-cs5535
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver
DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_CS5535_GPIO \
- CONFIG_GPIO_CS5535
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.32)),1)
+ KCONFIG:=CONFIG_CS5535_GPIO
FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
-else
- FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
- AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
-endif
endef
define KernelPackage/gpio-cs5535/description
@@ -185,6 +179,24 @@ endef
$(eval $(call KernelPackage,gpio-cs5535))
+define KernelPackage/gpio-cs5535-new
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
+ DEPENDS:=@TARGET_x86
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
+ KCONFIG:=CONFIG_GPIO_CS5535 CONFIG_PCI CONFIG_GPIOLIB
+ FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
+endif
+endef
+
+define KernelPackage/gpio-cs5535-new/description
+ This package contains the new AMD CS5535/CS5536 GPIO driver
+endef
+
+$(eval $(call KernelPackage,gpio-cs5535-new))
+
+
define KernelPackage/gpio-dev
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic GPIO char device support