aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-11-29 17:09:58 -0800
committerFelix Fietkau <nbd@nbd.name>2016-12-04 11:41:51 +0100
commit5763e438f672c50c8ef6b46ca0a9cc7f02309b00 (patch)
tree17fc27eac9dcf10dd52e7e40dd1ca6401185b3ff /package
parenta909a5d676e97531c08650c9aa07ac06cf30532e (diff)
downloadupstream-5763e438f672c50c8ef6b46ca0a9cc7f02309b00.tar.gz
upstream-5763e438f672c50c8ef6b46ca0a9cc7f02309b00.tar.bz2
upstream-5763e438f672c50c8ef6b46ca0a9cc7f02309b00.zip
kernel: add kernel package for the rs5c372a rtc module
This RTC is used on the Buffalo Terastation Pro II/Live devices. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 5ba0e5e420..e1b1e16d1d 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -666,6 +666,22 @@ endef
$(eval $(call KernelPackage,rtc-snvs))
+define KernelPackage/rtc-rs5c372a
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Ricoh R2025S/D, RS5C372A/B, RV5C386, RV5C387A
+ DEPENDS:=@RTC_SUPPORT +kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_RS5C372 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-rs5c372.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-rs5c372,1)
+endef
+
+define KernelPackage/rtc-rs5c372a/description
+ Kernel module for Ricoh R2025S/D, RS5C372A/B, RV5C386, RV5C387A RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-rs5c372a))
+
define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)