aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
commit6b63716262b89bec53402817876116898936d5f4 (patch)
tree1d792a9083d34dc6e40620b3c5802e9168a461e0 /package
parent14ed3f0f22f34b337bb58b2a5fd09e887df3331f (diff)
downloadupstream-6b63716262b89bec53402817876116898936d5f4.tar.gz
upstream-6b63716262b89bec53402817876116898936d5f4.tar.bz2
upstream-6b63716262b89bec53402817876116898936d5f4.zip
add preliminary support for musl
Musl is an alternative C-library, see http://www.musl-libc.org for more infos. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34314
Diffstat (limited to 'package')
-rw-r--r--package/hotplug2/Makefile2
-rw-r--r--package/libs/libbsd/Makefile2
-rw-r--r--package/toolchain/Makefile10
3 files changed, 12 insertions, 2 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 793393458d..085dccbee9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -29,7 +29,7 @@ define Package/hotplug2
VERSION:=1.0-beta-$(PKG_RELEASE)
TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
URL:=http://isteve.bofh.cz/~isteve/hotplug2/
- DEPENDS:=+!USE_UCLIBC:libbsd
+ DEPENDS:=+!(USE_UCLIBC||USE_MUSL):libbsd
endef
define Package/hotplug2/description
diff --git a/package/libs/libbsd/Makefile b/package/libs/libbsd/Makefile
index fe95bc9924..ce1de4bb36 100644
--- a/package/libs/libbsd/Makefile
+++ b/package/libs/libbsd/Makefile
@@ -18,7 +18,7 @@ PKG_INSTALL:=1
define Package/libbsd
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=@!USE_UCLIBC
+ DEPENDS:=@!(USE_UCLIBC||USE_MUSL)
TITLE:=common BSD library
endef
diff --git a/package/toolchain/Makefile b/package/toolchain/Makefile
index 265587ed5f..84fc3e6b2f 100644
--- a/package/toolchain/Makefile
+++ b/package/toolchain/Makefile
@@ -426,6 +426,16 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
+ define Package/musl/install
+ $(INSTALL_DIR) $(1)/lib
+ $(CP) \
+ $(TOOLCHAIN_DIR)/lib/ld-musl-*.so* \
+ $(1)/lib/
+ $(CP) \
+ $(TOOLCHAIN_DIR)/lib/libc.so* \
+ $(1)/lib/
+ endef
+
define Package/libc/install
$(call Package/$(LIBC)/install,$1)
endef