aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-05 20:25:11 +0000
committerJohn Crispin <john@openwrt.org>2015-03-05 20:25:11 +0000
commit700a53f8e26898cc12f87d1e8902c6071772fece (patch)
tree691ebccb4860bc90a9ac290e2469445bb94f728c /package
parentb48b7a7689b15754938c77449d59c16fc3765b1f (diff)
downloadupstream-700a53f8e26898cc12f87d1e8902c6071772fece.tar.gz
upstream-700a53f8e26898cc12f87d1e8902c6071772fece.tar.bz2
upstream-700a53f8e26898cc12f87d1e8902c6071772fece.zip
kernel: add ip_vti tunnel module
IP VTI (Virtual Tunnel Interface) is used to create a virtual device for IPsec VPN (similar to OpenVPN). Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> SVN-Revision: 44606
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 26dd491aec..a5a6474059 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -405,6 +405,22 @@ endef
$(eval $(call KernelPackage,iptunnel))
+define KernelPackage/ipvti
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=IP VTI (Virtual Tunnel Interface)
+ DEPENDS:=+kmod-iptunnel +kmod-iptunnel4 +kmod-ipsec4
+ KCONFIG:=CONFIG_NET_IPVTI
+ FILES:=$(LINUX_DIR)/net/ipv4/ip_vti.ko
+ AUTOLOAD:=$(call AutoLoad,33,ip_vti)
+endef
+
+define KernelPackage/ipvti/description
+ Kernel modules for IP VTI (Virtual Tunnel Interface)
+endef
+
+$(eval $(call KernelPackage,ipvti))
+
+
define KernelPackage/iptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 tunneling