aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 15:52:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 15:52:10 +0000
commit80b3c0875ac67d61815db65b2a7850dbb67625db (patch)
tree6973f114f3ed279a168a3b489647ad5e08de39e0 /package
parent8cb5cc2a79dbf863e6bd186773e70bb95293b0df (diff)
downloadupstream-80b3c0875ac67d61815db65b2a7850dbb67625db.tar.gz
upstream-80b3c0875ac67d61815db65b2a7850dbb67625db.tar.bz2
upstream-80b3c0875ac67d61815db65b2a7850dbb67625db.zip
kernel/modules: package module for OpenFirmware I2C accessors
SVN-Revision: 16921
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/i2c.mk20
1 files changed, 17 insertions, 3 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 67713f300d..ab77d53189 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -126,10 +126,26 @@ endef
$(eval $(call KernelPackage,i2c-scx200-acb))
+define KernelPackage/of-i2c
+ SUBMENU:=$(I2C_MENU)
+ TITLE:=OpenFirmware I2C accessors
+ DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx kmod-i2c-core
+ KCONFIG:=CONFIG_OF_I2C
+ FILES:=$(LINUX_DIR)/drivers/of/of_i2c.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,58,of_i2c)
+endef
+
+define KernelPackage/of-i2c/description
+ Kernel module for OpenFirmware I2C accessors.
+endef
+
+$(eval $(call KernelPackage,of-i2c))
+
+
define KernelPackage/i2c-ibm-iic
SUBMENU:=$(I2C_MENU)
TITLE:=IBM PPC 4xx on-chip I2C interface support
- DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx +kmod-i2c-core
+ DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx +kmod-i2c-core +kmod-of-i2c
KCONFIG:=CONFIG_I2C_IBM_IIC
FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-ibm_iic.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,59,i2c-ibm_iic)
@@ -140,5 +156,3 @@ define KernelPackage/i2c-ibm-iic/description
endef
$(eval $(call KernelPackage,i2c-ibm-iic))
-
-