aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-08-29 10:08:30 +0000
committerJohn Crispin <john@openwrt.org>2012-08-29 10:08:30 +0000
commit8703cf92d0bd9f28b221c0b223482ebc587c8790 (patch)
treea5883550e741e4ba6ffd81f200e6d32cc9d0fa1c /package
parent95738d97a9ee2773a672b6a408651b4c58dc27e7 (diff)
downloadupstream-8703cf92d0bd9f28b221c0b223482ebc587c8790.tar.gz
upstream-8703cf92d0bd9f28b221c0b223482ebc587c8790.tar.bz2
upstream-8703cf92d0bd9f28b221c0b223482ebc587c8790.zip
revert threadsafe patch
SVN-Revision: 33292
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 123f393d5a..d95783aac9 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -58,7 +58,7 @@ define Package/openssl-util
$(call Package/openssl/Default)
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libopenssl +libpthread
+ DEPENDS:=+libopenssl
TITLE+= (utility)
endef
@@ -105,7 +105,7 @@ define Build/Configure
)
endef
-TARGET_CFLAGS += $(FPIC) -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE
+TARGET_CFLAGS += $(FPIC)
define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,