aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-21 00:59:14 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-21 00:59:14 +0000
commitf1f5ea2739d9285bc2d7ab6376fee58b70ec0d89 (patch)
tree2acb86c35245e9b3a30e7418a36492a1f1b29880 /package
parentefff03d1441c28503d1f79cf1775ff099570e198 (diff)
downloadupstream-f1f5ea2739d9285bc2d7ab6376fee58b70ec0d89.tar.gz
upstream-f1f5ea2739d9285bc2d7ab6376fee58b70ec0d89.tar.bz2
upstream-f1f5ea2739d9285bc2d7ab6376fee58b70ec0d89.zip
e2fsprogs: use select-style dependencies, don't ship dev shlib symlink
SVN-Revision: 18866
Diffstat (limited to 'package')
-rw-r--r--package/e2fsprogs/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index c05105aab7..bf744147bb 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -49,7 +49,7 @@ endef
define Package/uuidgen
$(call Package/e2fsprogs)
- DEPENDS:=libuuid
+ DEPENDS:=+libuuid
TITLE:=Command line utility to create a new UUID value
endef
@@ -86,25 +86,25 @@ endef
define Package/tune2fs
$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem tune utility
- DEPENDS:=e2fsprogs
+ DEPENDS:= +e2fsprogs
endef
define Package/resize2fs
$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem resize utility
- DEPENDS:=e2fsprogs
+ DEPENDS:= +e2fsprogs
endef
define Package/badblocks
$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem badblocks utility
- DEPENDS:=e2fsprogs
+ DEPENDS:= +e2fsprogs
endef
define Package/blkid
$(call Package/e2fsprogs)
TITLE:=Command-line utility to locate/print block device attributes
- DEPENDS:=libuuid libblkid
+ DEPENDS:=+libuuid +libblkid
endef
TARGET_CFLAGS += $(FPIC)
@@ -177,7 +177,7 @@ endef
define Package/libext2fs/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so.* $(1)/usr/lib/
endef
define Package/tune2fs/install