aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2019-03-17 21:01:17 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-01-05 02:16:24 +0000
commitf246dfde3386ed4447afe080265ec75440ed5485 (patch)
tree146e70df6826f9f687cac0935296651a71d2bd4d /package
parent9c845a5ad1f20bc19fcc0af1e7d160c3b3f635aa (diff)
downloadupstream-f246dfde3386ed4447afe080265ec75440ed5485.tar.gz
upstream-f246dfde3386ed4447afe080265ec75440ed5485.tar.bz2
upstream-f246dfde3386ed4447afe080265ec75440ed5485.zip
hostapd: wpa_supplicant: Enable proper GCMP cipher support
This patch enables hostapd.sh to properly configure wpa_supplicant for when GCMP is used as cipher in station mode. Without this wpa_supplicant will be unable to connect to AP. This is needed for wil6210 as it does not support CCMP. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh5
2 files changed, 6 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f746f5455a..8e9605fe68 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=21
+PKG_RELEASE:=22
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 80e1f7cedf..0f6741336b 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -1312,6 +1312,11 @@ wpa_supplicant_add_network() {
;;
esac
+ [ "$wpa_cipher" = GCMP ] && {
+ append network_data "pairwise=GCMP" "$N$T"
+ append network_data "group=GCMP" "$N$T"
+ }
+
[ "$mode" = mesh ] || {
case "$wpa" in
1)