aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-22 08:38:10 +0000
commitd31a7b51abc91241870e907ff76ce7058aceefa1 (patch)
tree920f2dabb56d1bae95a670b63ff37ef2ae33f68f /target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
parentc28af661ee0a71d7964358a41d19dcc86737f19b (diff)
downloadupstream-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.gz
upstream-d31a7b51abc91241870e907ff76ce7058aceefa1.tar.bz2
upstream-d31a7b51abc91241870e907ff76ce7058aceefa1.zip
add experimental support for 2.6.30
SVN-Revision: 15979
Diffstat (limited to 'target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..69f1035505
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o