aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:52:34 +0000
commit89f3773ca4b4e278728ccf83e29e5bf117484663 (patch)
tree6bf5f02cf46042e7e0d8064dbb3352aec869adce /target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch
parente16f20b51813c4ef7d2519235d45fa37bd09e2ac (diff)
downloadupstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.gz
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.tar.bz2
upstream-89f3773ca4b4e278728ccf83e29e5bf117484663.zip
adm5120: preliminary 2.6.32 support (closes: #6304)
SVN-Revision: 19005
Diffstat (limited to 'target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch
new file mode 100644
index 0000000000..cf6350c8cb
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.32/003-adm5120_switch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -602,6 +602,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config ADM5120_ENET
++ tristate "ADM5120 Ethernet switch support"
++ depends on ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -208,6 +208,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o