aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
commit93993b29e0c89d87d13c022753739ebe953c1d19 (patch)
tree791dfbf8b9ce7c95be2ccafa14dce8316c69ce51 /target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
parent9bc1e548a19f05e2bafad0461b9ae0b34654cf2a (diff)
downloadupstream-93993b29e0c89d87d13c022753739ebe953c1d19.tar.gz
upstream-93993b29e0c89d87d13c022753739ebe953c1d19.tar.bz2
upstream-93993b29e0c89d87d13c022753739ebe953c1d19.zip
adm5120: add kernel 2.6.35 preliminary support
SVN-Revision: 21751
Diffstat (limited to 'target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..69f1035505
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o