aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-10 11:21:10 +0000
commit93993b29e0c89d87d13c022753739ebe953c1d19 (patch)
tree791dfbf8b9ce7c95be2ccafa14dce8316c69ce51 /target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
parent9bc1e548a19f05e2bafad0461b9ae0b34654cf2a (diff)
downloadupstream-93993b29e0c89d87d13c022753739ebe953c1d19.tar.gz
upstream-93993b29e0c89d87d13c022753739ebe953c1d19.tar.bz2
upstream-93993b29e0c89d87d13c022753739ebe953c1d19.zip
adm5120: add kernel 2.6.35 preliminary support
SVN-Revision: 21751
Diffstat (limited to 'target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
new file mode 100644
index 0000000000..5bb36432ab
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -88,6 +88,7 @@ obj-$(CONFIG_PATA_QDI) += pata_qdi.o
+ obj-$(CONFIG_PATA_RB532) += pata_rb532_cf.o
+ obj-$(CONFIG_PATA_RZ1000) += pata_rz1000.o
+ obj-$(CONFIG_PATA_WINBOND_VLB) += pata_winbond.o
++obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
+
+ # Should be last but two libata driver
+ obj-$(CONFIG_PATA_ACPI) += pata_acpi.o
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -604,6 +604,15 @@ config PATA_RADISYS
+
+ If unsure, say N.
+
++config PATA_RB153_CF
++ tristate "RouterBOARD 153 Compact Flash support"
++ depends on ADM5120_MACH_RB_153
++ help
++ This option enables support for a Compact Flash connected on
++ the RouterBOARD 153.
++
++ If unsure, say N.
++
+ config PATA_RB532
+ tristate "RouterBoard 532 PATA CompactFlash support"
+ depends on MIKROTIK_RB532