aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/profiles/RB1xx.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/adm5120/profiles/RB1xx.mk
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/adm5120/profiles/RB1xx.mk')
-rw-r--r--target/linux/adm5120/profiles/RB1xx.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/adm5120/profiles/RB1xx.mk b/target/linux/adm5120/profiles/RB1xx.mk
new file mode 100644
index 0000000000..9dd3de0973
--- /dev/null
+++ b/target/linux/adm5120/profiles/RB1xx.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RouterBoard
+ NAME:=RouterBoard RB1xx
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/RouterBoard/Description
+ Package set compatible with the RouterBoard RB1xx devices. Contains RouterOS to OpenWrt\\\
+ installation scripts.
+endef
+$(eval $(call Profile,RouterBoard))