aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/sata
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-10-07 20:29:03 +0200
committerFelix Fietkau <nbd@nbd.name>2016-10-13 17:04:33 +0200
commit4fc48a8cf29bfc6997384c2aa4c72d0b9e6b3313 (patch)
treeb49d3debdbb0655c8937c9ecba37f09fae73c4a8 /target/linux/apm821xx/sata
parent4104613fae1ebf958cd5957aa336e1b3e53497bb (diff)
downloadupstream-4fc48a8cf29bfc6997384c2aa4c72d0b9e6b3313.tar.gz
upstream-4fc48a8cf29bfc6997384c2aa4c72d0b9e6b3313.tar.bz2
upstream-4fc48a8cf29bfc6997384c2aa4c72d0b9e6b3313.zip
apm821xx: replace recovery image for the MBL with initramfs
The patch "images: bump default rootfs size to 256 MB" a1f83bad606411a561e8e60110c71232b1a28aa2 caused a crash during boot for the recovery images. This is because both variants of the MyBook Live only have 256MB of RAM and for the recovery option, the ext4 rootfs was simply stored in the RAMDISK. This patch replaces recovery image for the MBL with an initramfs kernel. In order to boot the initramfs (for recovery or development): 0. copy the initramfs and device tree into tftp's server directory # cp *-initramfs-kernel.bin to /tftp-server/mbl.bin # cp *-ext4-kernel.dtb to /tftp-server/fdt.bin 1. Connect the MyBook Live (Duo) serial port. (Warning! Use a 3.3v level shifter). 2. Hit Enter during u-boot and insert these three lines: # setenv serverip 192.168.1.254; setenv ipaddr 192.168.1.1; # tftp ${kernel_addr_r} mbl.bin; tftp ${fdt_addr_r} fdt.bin # run addtty addmisc; bootm ${kernel_addr_r} - ${fdt_addr_r} Where 192.168.1.254 is your TFTP server. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/sata')
-rw-r--r--target/linux/apm821xx/sata/config-default5
-rw-r--r--target/linux/apm821xx/sata/target.mk2
2 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/apm821xx/sata/config-default b/target/linux/apm821xx/sata/config-default
index 5abc105350..b8342de049 100644
--- a/target/linux/apm821xx/sata/config-default
+++ b/target/linux/apm821xx/sata/config-default
@@ -17,7 +17,6 @@ CONFIG_SATA_DWC=y
CONFIG_EXT4_FS=y
CONFIG_SCSI=y
CONFIG_BLK_DEV_SD=y
-CONFIG_BLK_DEV_RAM=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_GENERIC_PLATFORM=y
@@ -26,9 +25,6 @@ CONFIG_LEDS_TRIGGER_DISK=y
CONFIG_BLK_DEV_DM=y
CONFIG_BLK_DEV_DM_BUILTIN=y
CONFIG_BLK_DEV_MD=y
-CONFIG_BLK_DEV_RAM=y
-CONFIG_BLK_DEV_RAM_COUNT=16
-CONFIG_BLK_DEV_RAM_SIZE=4096
CONFIG_MD=y
CONFIG_MD_AUTODETECT=y
# CONFIG_MD_LINEAR is not set
@@ -37,7 +33,6 @@ CONFIG_MD_RAID0=y
CONFIG_MD_RAID1=y
# CONFIG_MD_RAID10 is not set
# CONFIG_MD_RAID456 is not set
-CONFIG_BLK_DEV_RAM_SIZE=50331648
CONFIG_PPC_EARLY_DEBUG=y
CONFIG_PPC_EARLY_DEBUG_44x=y
# CONFIG_PPC_EARLY_DEBUG_MEMCONS is not set
diff --git a/target/linux/apm821xx/sata/target.mk b/target/linux/apm821xx/sata/target.mk
index c652fe40eb..1c7856828c 100644
--- a/target/linux/apm821xx/sata/target.mk
+++ b/target/linux/apm821xx/sata/target.mk
@@ -1,5 +1,5 @@
BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb
+FEATURES += ext4 usb ramdisk
DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
kmod-dm kmod-md-mod partx-utils