aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-03-21 20:58:16 +0100
committerChristian Lamparter <chunkeey@gmail.com>2020-03-22 23:02:09 +0100
commit01fe7a2b64091786b6518025641f17c725a7769b (patch)
tree29ca328b195b0dffd2fd0ee87158fa79eea58f95 /target/linux/apm821xx
parent0409fe64cfc36cd1ed582900dea2c86b5126a61b (diff)
downloadupstream-01fe7a2b64091786b6518025641f17c725a7769b.tar.gz
upstream-01fe7a2b64091786b6518025641f17c725a7769b.tar.bz2
upstream-01fe7a2b64091786b6518025641f17c725a7769b.zip
apm821xx: add drivetemp sensor for the WD MyBook Series
This patch adds the hwmon-drivetemp to the device. It also adds device-tree bindings. This can be useful to automate external fans which can be controlled for example by either an unused sata-port or by the usb-power regulator. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/dts/wd-mybooklive.dts10
-rw-r--r--target/linux/apm821xx/sata/target.mk2
2 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/apm821xx/dts/wd-mybooklive.dts b/target/linux/apm821xx/dts/wd-mybooklive.dts
index 6cba7d2f26..82e9497ecd 100644
--- a/target/linux/apm821xx/dts/wd-mybooklive.dts
+++ b/target/linux/apm821xx/dts/wd-mybooklive.dts
@@ -179,10 +179,20 @@
&SATA0 {
status = "okay";
+
+ drive0: sata-port@0 {
+ reg = <0>;
+ #thermal-sensor-cells = <0>;
+ };
};
&SATA1 {
status = "okay";
+
+ drive1: sata-port@0 {
+ reg = <0>;
+ #thermal-sensor-cells = <0>;
+ };
};
&UART0 {
diff --git a/target/linux/apm821xx/sata/target.mk b/target/linux/apm821xx/sata/target.mk
index 790746c480..d3af6ef821 100644
--- a/target/linux/apm821xx/sata/target.mk
+++ b/target/linux/apm821xx/sata/target.mk
@@ -1,6 +1,6 @@
BOARDNAME := Devices which boot from SATA (NAS)
FEATURES += ext4 usb ramdisk squashfs rootfs-part boot-part
-DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
+DEFAULT_PACKAGES += badblocks block-mount e2fsprogs kmod-hwmon-drivetemp \
kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck
define Target/Description