aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/netgear.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-23 19:33:07 +0200
committerJohn Crispin <john@phrozen.org>2016-06-23 19:33:31 +0200
commit387477350334daf8cd6adf72f63eddae83785614 (patch)
treeffa65aadbb9341ec560af9cd21879e8822e46ac2 /target/linux/ar71xx/generic/profiles/netgear.mk
parentcb7aa4b1fee688342950d02195b927962295514e (diff)
downloadupstream-387477350334daf8cd6adf72f63eddae83785614.tar.gz
upstream-387477350334daf8cd6adf72f63eddae83785614.tar.bz2
upstream-387477350334daf8cd6adf72f63eddae83785614.zip
Revert "ar71xx: fix legacy image building"
This reverts commit 59e98b27c93d282edb62fad756fd1c1e587c067f. and Revert "ar71xx: merge profiles into image building code" This reverts commit 636089ead6864364798ac988299429d171051c0e. these are still causing issues Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/netgear.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk96
1 files changed, 96 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
new file mode 100644
index 0000000000..2bce721244
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -0,0 +1,96 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDAP360
+ NAME:=NETGEAR WNDAP360
+ PACKAGES:=
+endef
+
+define Profile/WNDAP360/Description
+ Package set optimized for the NETGEAR WNDAP360
+endef
+
+$(eval $(call Profile,WNDAP360))
+
+define Profile/WNDR3700
+ NAME:=NETGEAR WNDR3700/WNDR3800/WNDRMAC
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev kmod-leds-wndr3700-usb
+endef
+
+define Profile/WNDR3700/Description
+ Package set optimized for the NETGEAR WNDR3700/WNDR3800/WNDRMAC
+endef
+
+$(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNR2000V3
+ NAME:=NETGEAR WNR2000V3
+ PACKAGES:= -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-ledtrig-usbdev
+endef
+
+define Profile/WNR2000V3/Description
+ Package set optimized for the NETGEAR WNR2000V3
+endef
+
+$(eval $(call Profile,WNR2000V3))
+
+
+define Profile/WNR2000V4
+ NAME:=NETGEAR WNR2000V4
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNR2000V4/Description
+ Package set optimized for the NETGEAR WNR2000V4
+endef
+
+$(eval $(call Profile,WNR2000V4))
+
+
+define Profile/WNR612V2
+ NAME:=NETGEAR WNR612V2 / On Networks N150
+endef
+
+define Profile/WNR612V2/Description
+ Package set optimized for the NETGEAR WNR612V2 / On Networks N150
+endef
+
+$(eval $(call Profile,WNR612V2))
+
+
+define Profile/WNR1000V2
+ NAME:=NETGEAR WNR1000V2
+endef
+
+define Profile/WNR1000V2/Description
+ Package set optimized for the NETGEAR WNR1000V2
+endef
+
+$(eval $(call Profile,WNR1000V2))
+
+
+define Profile/WNR2200
+ NAME:=NETGEAR WNR2200
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNR2200/Description
+ Package set optimized for the NETGEAR WNR2200
+endef
+
+$(eval $(call Profile,WNR2200))
+
+define Profile/WPN824N
+ NAME:=NETGEAR WPN824N
+endef
+
+define Profile/WPN824N/Description
+ Package set optimized for the NETGEAR WPN824N
+endef
+
+$(eval $(call Profile,WPN824N))