aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorChristian Mehlis <christian@m3hlis.de>2017-03-28 21:14:49 +0200
committerJohn Crispin <john@phrozen.org>2017-03-29 09:04:08 +0200
commit0af487033e6af390686ed2bc693beab7b467eaf3 (patch)
treeccbbd82063e71f42346b23d56401ce8ff2f3a3bb /target/linux/ar71xx/image/generic.mk
parentf5ece7326adfbc115ae66cf958d510532e064cfb (diff)
downloadupstream-0af487033e6af390686ed2bc693beab7b467eaf3.tar.gz
upstream-0af487033e6af390686ed2bc693beab7b467eaf3.tar.bz2
upstream-0af487033e6af390686ed2bc693beab7b467eaf3.zip
ar71xx: move Compex WPJ344 to generic build target
Signed-off-by: Christian Mehlis <christian@m3hlis.de>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 434ae695aa..54835a5634 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -790,6 +790,16 @@ define Device/bhr-4grv2
endef
TARGET_DEVICES += bhr-4grv2
+define Device/wpj344
+ DEVICE_TITLE := Compex WPJ344 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME := WPJ344
+ MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+ IMAGE_SIZE := 16128k
+ CONSOLE := ttyS0,115200
+endef
+TARGET_DEVICES += wpj344
+
define Device/wpj531
DEVICE_TITLE := Compex WPJ531 (16MB flash)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport