aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-03-30 21:52:20 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-15 22:43:33 +0200
commit1c56a7929ac09b7bc2622aaa08cf3a206c480011 (patch)
treee350ce112dafb7a1f00c37df7b246453ad84716b /target/linux/ar71xx/image/generic.mk
parente71b2dad948749d044592a730fa9019d45abe090 (diff)
downloadupstream-1c56a7929ac09b7bc2622aaa08cf3a206c480011.tar.gz
upstream-1c56a7929ac09b7bc2622aaa08cf3a206c480011.tar.bz2
upstream-1c56a7929ac09b7bc2622aaa08cf3a206c480011.zip
ar71xx: move Zbtlink ZBT-WE1526 to generic build target
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index ebcb183b03..33db5865bf 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -834,3 +834,15 @@ define Device/wpj563
IMAGE_SIZE := 16128k
endef
TARGET_DEVICES += wpj563
+
+define Device/zbt-we1526
+ DEVICE_TITLE := Zbtlink ZBT-WE1526
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME := ZBT-WE1526
+ IMAGE_SIZE := 16000k
+ KERNEL_SIZE := 1472k
+ ROOTFS_SIZE := 14528k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += zbt-we1526