aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-01-20 06:39:35 +0100
committerJohn Crispin <john@phrozen.org>2017-01-20 06:43:13 +0100
commit236fcedc51d0b43701081ddde7af39e6a6cce0e7 (patch)
tree183844ddde7f45f7757bca455a48cd108eb75dce /target/linux/ar71xx/image/generic.mk
parent54e980aa36522de91ba8c4a187cbaef8be6c710a (diff)
downloadupstream-236fcedc51d0b43701081ddde7af39e6a6cce0e7.tar.gz
upstream-236fcedc51d0b43701081ddde7af39e6a6cce0e7.tar.bz2
upstream-236fcedc51d0b43701081ddde7af39e6a6cce0e7.zip
Revert "ar71xx: wrt400n: lift size limit on kernel and rootfs part"
This reverts commit 78c2ec0f477bab5b5c2622b5a18c14e51dea7249. The builders were failing with a segfault when generating the image Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk22
1 files changed, 0 insertions, 22 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 37ee755ee4..ab64e76d7c 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -766,25 +766,3 @@ define Device/bhr-4grv2
IMAGE/factory.bin = append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | mkbuffaloimg
endef
TARGET_DEVICES += bhr-4grv2
-
-
-# factory image starts with a header of size 60 (0x3c) bytes. The header is
-# only used for checking integrity of the firmware image without being written
-# to flash chip. That means it's okay we include jffs2 pads when computing
-# checksums
-define Build/wrt400n-factory
- cp $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).tmp
- $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS).tmp $(BLOCKSIZE:%k=%)
- $(STAGING_DIR_HOST)/bin/wrt400n $(IMAGE_KERNEL) $(IMAGE_ROOTFS).tmp $@
- rm -f $(IMAGE_ROOTFS).tmp
-endef
-
-define Device/wrt400n
- DEVICE_TITLE := Linksys WRT400N
- BOARDNAME := WRT400N
- CONSOLE := ttyS0,115200
- IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size 0x770000
- IMAGE/factory.bin = wrt400n-factory | check-size 0x77003c
-endef
-TARGET_DEVICES += wrt400n