aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-05-29 22:07:04 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-30 14:34:09 +0200
commit6173f6d8f11961709eabfc871f40905ebbc2d274 (patch)
tree64ad40fb4f202d75719915fcda61423129c53646 /target/linux/ar71xx/image/generic.mk
parent18d5cee2a8c0bcddbbcca964bf95bed58d286b9d (diff)
downloadupstream-6173f6d8f11961709eabfc871f40905ebbc2d274.tar.gz
upstream-6173f6d8f11961709eabfc871f40905ebbc2d274.tar.bz2
upstream-6173f6d8f11961709eabfc871f40905ebbc2d274.zip
ar71xx: move Wallys DR344 to generic build target
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 33db5865bf..8472b904cc 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -213,6 +213,16 @@ define Device/mr16
endef
TARGET_DEVICES += mr16
+define Device/dr344
+ DEVICE_TITLE := Wallys DR344
+ BOARDNAME = DR344
+ KERNEL_SIZE := 1408k
+ IMAGE_SIZE = 7744k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 6336k | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += dr344
+
define Device/dr531
DEVICE_TITLE := Wallys DR531
DEVICE_PACKAGES := kmod-usb-core kmod-usb2