aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-06-08 21:41:25 +0200
committerMathias Kresin <dev@kresin.me>2018-06-09 13:45:29 +0200
commit9ec117c5be83f296b8af7862291ea0b70bb1e0e6 (patch)
tree37723f0bb731d659ae2591c600a597a309bcc7af /target/linux/ar71xx/image/generic.mk
parentc8677ca89e53e3be7988d54280fce166cc894a7e (diff)
downloadupstream-9ec117c5be83f296b8af7862291ea0b70bb1e0e6.tar.gz
upstream-9ec117c5be83f296b8af7862291ea0b70bb1e0e6.tar.bz2
upstream-9ec117c5be83f296b8af7862291ea0b70bb1e0e6.zip
ar71xx: fix AVM package selection
The AVM package selection partially broke with the addition of the FRITZ!Box 4020. This commit restores the intended behavior. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index e57f8a2731..05eeeebaad 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -1318,7 +1318,7 @@ endef
define Device/fritz300e
$(call Device/AVM)
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
- DEVICE_PACKAGES := rssileds -swconfig
+ DEVICE_PACKAGES += rssileds -swconfig
BOARDNAME := FRITZ300E
SUPPORTED_DEVICES := fritz300e
IMAGE_SIZE := 15232k
@@ -1328,7 +1328,7 @@ TARGET_DEVICES += fritz300e
define Device/fritz4020
$(call Device/AVM)
DEVICE_TITLE := AVM FRITZ!Box 4020
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
+ DEVICE_PACKAGES += kmod-usb-core kmod-usb2 kmod-usb-storage
BOARDNAME := FRITZ4020
SUPPORTED_DEVICES := fritz4020
IMAGE_SIZE := 15232k