aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.26
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-09-18 12:56:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-09-18 12:56:10 +0000
commit219ec2a41982aa2e49ca06958fa66ef585be0b60 (patch)
tree65fedababb491d02d5e881114878dc4d7160e829 /target/linux/ar71xx/patches-2.6.26
parent264279d6d3260491c726b8c885e814bf66f3d09b (diff)
downloadupstream-219ec2a41982aa2e49ca06958fa66ef585be0b60.tar.gz
upstream-219ec2a41982aa2e49ca06958fa66ef585be0b60.tar.bz2
upstream-219ec2a41982aa2e49ca06958fa66ef585be0b60.zip
add MyLoader support
SVN-Revision: 12627
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.26')
-rw-r--r--target/linux/ar71xx/patches-2.6.26/300-mips_fw_myloader.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.26/300-mips_fw_myloader.patch b/target/linux/ar71xx/patches-2.6.26/300-mips_fw_myloader.patch
new file mode 100644
index 0000000000..4ab8b75213
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.26/300-mips_fw_myloader.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -158,6 +158,7 @@
+ #
+ libs-$(CONFIG_ARC) += arch/mips/fw/arc/
+ libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER) += arch/mips/fw/myloader/
+ libs-$(CONFIG_SNIPROM) += arch/mips/fw/sni/
+ libs-y += arch/mips/fw/lib/
+ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/sibyte/cfe/
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -873,6 +873,9 @@
+ config MIPS_DISABLE_OBSOLETE_IDE
+ bool
+
++config MYLOADER
++ bool
++
+ config SYNC_R4K
+ bool
+