aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-04-23 20:14:48 +0000
commit8b82de7aa00be10315a8d1c514e3026ab590ce88 (patch)
tree643cfcebbb3de70623160f3bdea175c18676f3cd /target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
parentb60fc68fa8587e17dc555b9163a86a3dbf93c922 (diff)
downloadupstream-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.gz
upstream-8b82de7aa00be10315a8d1c514e3026ab590ce88.tar.bz2
upstream-8b82de7aa00be10315a8d1c514e3026ab590ce88.zip
add initial support for 2.6.29
SVN-Revision: 15357
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..7bd72c1d55
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.29/005-ar71xx_mac_driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -2068,6 +2068,8 @@ config ACENIC_OMIT_TIGON_I
+
+ The safe and default value for this is N.
+
++source drivers/net/ag71xx/Kconfig
++
+ config DL2K
+ tristate "DL2000/TC902x-based Gigabit Ethernet support"
+ depends on PCI
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Linux network (ethercard) device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_E1000) += e1000/
+ obj-$(CONFIG_E1000E) += e1000e/
+ obj-$(CONFIG_IBM_NEW_EMAC) += ibm_newemac/