aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
commit852451deeb3a3dec609521bf7730912ccf6b50e5 (patch)
treec9a86fcb972e1e498c84709e7f5b022689b51879 /target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
parent167120730bed3bcfdc7585db3f0d4a191481d15d (diff)
downloadupstream-852451deeb3a3dec609521bf7730912ccf6b50e5.tar.gz
upstream-852451deeb3a3dec609521bf7730912ccf6b50e5.tar.bz2
upstream-852451deeb3a3dec609521bf7730912ccf6b50e5.zip
add patches for 2.6.31
SVN-Revision: 17366
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..d8f61bb909
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.31/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -279,6 +279,11 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
+
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+