aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
commitd45dc5e820b5589662236143a68928eaec01e83e (patch)
tree64a1434b436174e77545a6b7234612c5f0fdb3da /target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch
parentbef7ceff095e5e648b45b4cf0c73fb7ad588b676 (diff)
downloadupstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.gz
upstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.bz2
upstream-d45dc5e820b5589662236143a68928eaec01e83e.zip
ar71xx: add kernel 2.6.35 preliminary support
SVN-Revision: 21734
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch b/target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch
new file mode 100644
index 0000000000..b98b84da37
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.35/207-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -301,6 +301,10 @@ config LEDS_WNDR3700_USB
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && AR71XX_MACH_RB750
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGER_TIMER
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
+ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
++obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o