aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-08-09 15:59:41 +0200
committerJohn Crispin <john@phrozen.org>2018-08-22 08:09:00 +0200
commit318e19ba6755105bb6cc19937d8fff26cbd2cc6f (patch)
tree2f7c96140932a2770fb767141c7d1e93d29127b0 /target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch
parente5f56c07d7fab9a6f2201f4100b593349b8ef67d (diff)
downloadupstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.tar.gz
upstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.tar.bz2
upstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.zip
ar71xx: add v4.14 support
adds v4.14 patches for testing but leaves v4.9 as default for now. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch b/target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch
new file mode 100644
index 0000000000..777a0df917
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.14/441-leds-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -666,6 +666,10 @@ config LEDS_WNDR3700_USB
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && ATH79_MACH_RB750
++
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
+ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
++obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+ obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
+ obj-$(CONFIG_LEDS_ASIC3) += leds-asic3.o