aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/tiny/profiles/00-default.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-12 16:36:13 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-13 19:54:45 +0100
commit0cd5e85e7ad621223b0787e66d8ad20fb2694135 (patch)
treecbd859d17f19d37696696c0e28fe4e58546180b5 /target/linux/ar71xx/tiny/profiles/00-default.mk
parent29d126b5c13a8581cbc0961523eb3fd60320111d (diff)
downloadupstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.tar.gz
upstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.tar.bz2
upstream-0cd5e85e7ad621223b0787e66d8ad20fb2694135.zip
ar71xx: create new ar71xx/tiny subtarget for 4MB flash devices
This new subtarget sets the small_flash flag and removes unused kernel configuration. small_flash removes KERNEL_KALLSYMS, which saves ~107KB in the default configuration; removing unneeded hardware support from ar71xx/tiny saves another ~18KB (both after LZMA). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ar71xx/tiny/profiles/00-default.mk')
-rw-r--r--target/linux/ar71xx/tiny/profiles/00-default.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/tiny/profiles/00-default.mk b/target/linux/ar71xx/tiny/profiles/00-default.mk
new file mode 100644
index 0000000000..d6d76086fd
--- /dev/null
+++ b/target/linux/ar71xx/tiny/profiles/00-default.mk
@@ -0,0 +1,11 @@
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ PRIORITY := 1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))