aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-11-05 12:53:55 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-11-05 16:00:06 +0100
commit860de2e1aa9deac7dce76b7f85cb5fcfbba00468 (patch)
tree48583d7b60392841a3d8383473918965ca83ae76 /target/linux/ar71xx
parentc764b2b531116d0bf7d285ac8fee29eea6a486cc (diff)
downloadupstream-860de2e1aa9deac7dce76b7f85cb5fcfbba00468.tar.gz
upstream-860de2e1aa9deac7dce76b7f85cb5fcfbba00468.tar.bz2
upstream-860de2e1aa9deac7dce76b7f85cb5fcfbba00468.zip
ar71xx: disable some tiny targets with kernel 4.14
The bump to kernel 4.14 caused a massive increase in kernel size. For most targets, switching them to dynamic partitioning allowed to cope with this. On some targets, the kernel partition is located behind the rootfs, which disallows switching to dynamic partitioning as the boot location would be altered, requiring a u-boot change. Also within the tiny section, which disables kernel symbols etc to decrease the image size, the partition size is still too small. Disable these targets for now, fixing image generation: - Buffalo BHR-4GRV2 - Zbtlink ZBT-WE1526 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/tiny.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/tiny.mk b/target/linux/ar71xx/image/tiny.mk
index 86ed2c7f2b..aabe68c2b9 100644
--- a/target/linux/ar71xx/image/tiny.mk
+++ b/target/linux/ar71xx/image/tiny.mk
@@ -9,7 +9,6 @@ define Device/bhr-4grv2
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
endef
-TARGET_DEVICES += bhr-4grv2
define Device/zbt-we1526
DEVICE_TITLE := Zbtlink ZBT-WE1526
@@ -21,4 +20,3 @@ define Device/zbt-we1526
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
endef
-TARGET_DEVICES += zbt-we1526 \ No newline at end of file