aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-05 18:41:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-05 18:41:18 +0000
commitc98db0707c2af5063b500d3e33aee8b8e49d2964 (patch)
tree30ecb39c416f8c22b05bb5b2f41d3ab762a6493d /target/linux/ar71xx
parentcc4b946fa2ed08a1ff99cc78e345e3cec1568368 (diff)
downloadupstream-c98db0707c2af5063b500d3e33aee8b8e49d2964.tar.gz
upstream-c98db0707c2af5063b500d3e33aee8b8e49d2964.tar.bz2
upstream-c98db0707c2af5063b500d3e33aee8b8e49d2964.zip
ar71xx: image: allow to use optional parameters for MkuImageLzma/initramfs
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38658
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 811da74bcf..c934dd4adc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -91,8 +91,8 @@ define MkuImageLzma
endef
define MkuImageLzma/initramfs
- $(call PatchKernelLzma,$(1),$(2),,-initramfs)
- $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
+ $(call PatchKernelLzma,$(1),$(2),$(3),-initramfs)
+ $(call MkuImage,lzma,$(4),$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
endef
define MkuImageGzip