aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-04-18 20:59:52 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-04-23 09:19:33 +0800
commit88468f7e5307a132a612d619a73936d030339892 (patch)
tree6b60e75fbd89d8e0e293b687852c978cdef088b4 /target/linux/arm64/Makefile
parentb889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a (diff)
downloadupstream-88468f7e5307a132a612d619a73936d030339892.tar.gz
upstream-88468f7e5307a132a612d619a73936d030339892.tar.bz2
upstream-88468f7e5307a132a612d619a73936d030339892.zip
armvirt: merge arm64 as subtarget 64
Original armvirt target is now subtarget 32. Other than that the built result should remain the same as before Besides old features already available with arm64, the new armvirt/64 subtarget will also have those features originally enabled for armvirt/32 with commit 44ecfc2 ("armvirt: new target") - pl011, uart - pl031, rtc - pl061, gpio - pci-host-generic - virtio_{mmio,pci,net,blk,scsi,9p,console,balloon} - smp with NR_CPUS=4 - cpu-hotplug - ext4 - DEBUG_BUGVERBOSE for debug purposes Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/arm64/Makefile')
-rw-r--r--target/linux/arm64/Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/arm64/Makefile b/target/linux/arm64/Makefile
deleted file mode 100644
index 5257b89c03..0000000000
--- a/target/linux/arm64/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-ARCH:=aarch64
-BOARD:=arm64
-BOARDNAME:=ARMv8 multiplatform
-FEATURES:=fpu ramdisk
-CFLAGS:=-Os -pipe -fno-caller-saves
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-KERNEL_PATCHVER:=4.9
-
-DEVICE_TYPE:=developerboard
-
-define Target/Description
- Build multi-platform images for the ARMv8 instruction set architecture
-endef
-
-include $(INCLUDE_DIR)/target.mk
-
-KERNELNAME:=Image dtbs
-
-$(eval $(call BuildTarget))