aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armvirt/image
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-12-08 23:21:30 +0800
committerJohn Crispin <john@phrozen.org>2016-12-16 07:56:35 +0100
commit44ecfc26eb22ca23668a5fd0c706d75f274e410a (patch)
treeb4b3df9deb3c5f8e62296723b0937694ecdb5c25 /target/linux/armvirt/image
parentfb237477fd1e7801e4877f9fe1ea7bc1ec16dd99 (diff)
downloadupstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.tar.gz
upstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.tar.bz2
upstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.zip
armvirt: new target
An ARM Cortex-A15 machine provided by QEMU. Kernel drivers enabled: - pl011, uart - pl031, rtc - pl061, gpio - pci-host-generic - virtio_{mmio,pci,net,blk,scsi,9p,console,balloon} - smp with NR_CPUS=4 - cpu-hotplug - ext4 - neon, vfp extensions support (otherwise userland will fail with illegal instruction signal (code 0x00000004)) - DEBUG_BUGVERBOSE for debug purposes Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/armvirt/image')
-rw-r--r--target/linux/armvirt/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
new file mode 100644
index 0000000000..df4383f1d4
--- /dev/null
+++ b/target/linux/armvirt/image/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNELNAME)
+endef
+
+define Image/Build/Initramfs
+ cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-$(KERNELNAME)-initramfs
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync | \
+ gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-root.$(1).gz
+endef
+
+$(eval $(call BuildImage))