aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-06 13:57:27 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-06 19:49:05 +0200
commit081e944be6684bf5c4ee7c9fa2683d568d5be288 (patch)
tree9f1942be74e4faef66c1fd8dee9b15dcc2b33d87 /target/linux/ath25/image
parent8938711223842facfd9a2a36ca4c589665c2c0ca (diff)
downloadupstream-081e944be6684bf5c4ee7c9fa2683d568d5be288.tar.gz
upstream-081e944be6684bf5c4ee7c9fa2683d568d5be288.tar.bz2
upstream-081e944be6684bf5c4ee7c9fa2683d568d5be288.zip
ath25: add back target support
Discussion on the mailing list reveals that this target has active users. As we are finally able to upgrade this target to kernel 5.4, add it back to master. This reverts commit 7d29a5571403 ("ath25: drop target") and immediately moves the relevant files to 5.4, without touching the content. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath25/image')
-rw-r--r--target/linux/ath25/image/Makefile115
1 files changed, 115 insertions, 0 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
new file mode 100644
index 0000000000..8066ba61a8
--- /dev/null
+++ b/target/linux/ath25/image/Makefile
@@ -0,0 +1,115 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/mkfwimage
+ $(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B $(1).$(VERSION_DIST).$(REVISION) \
+ -k $(IMAGE_KERNEL) \
+ -r $(IMAGE_ROOTFS) \
+ -o $@.new && \
+ mv $@.new $@
+endef
+
+define Build/combined-image
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(IMAGE_KERNEL)" \
+ "$(IMAGE_ROOTFS)" \
+ "$@.new" && \
+ mv $@.new $@
+endef
+
+define Build/mkmylofw
+ $(STAGING_DIR_HOST)/bin/mkmylofw -B $(1) \
+ -p0x020000:0x130000:ah:0x80041000:linux:$(IMAGE_KERNEL) \
+ -p0x150000:0x2a0000:::rootfs:$(IMAGE_ROOTFS) \
+ $@.new && \
+ mv $@.new $@
+endef
+
+define Build/gzip-kernel
+ gzip -9n -c $@ > $@.gz
+ dd if=$@.gz of=$@ bs=65536 conv=sync
+endef
+
+define Build/lzma-kernel
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $@.l7
+ dd if=$@.l7 of=$@ bs=65536 conv=sync
+endef
+
+define Build/copy-kernel
+ rm -f $@ $@.elf
+ cp $< $@
+ cp $< $@.elf
+endef
+
+define Build/elf-kernel
+ cp $(IMAGE_KERNEL).elf $@
+endef
+
+
+define Device/Default
+ PROFILES = Default $$(DEVICE_NAME)
+ KERNEL := copy-kernel | lzma-kernel
+ IMAGES := sysupgrade.bin
+ FILESYSTEMS := squashfs
+endef
+
+define Device/generic
+ DEVICE_VENDOR := Atheros
+ DEVICE_MODEL := Generic AR2xxx board
+ IMAGES := kernel.lzma kernel.elf kernel.gz rootfs.bin sysupgrade.bin
+ IMAGE/kernel.gz := elf-kernel | gzip-kernel
+ IMAGE/kernel.elf := elf-kernel
+ IMAGE/kernel.lzma := elf-kernel | lzma-kernel
+ IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | combined-image
+ IMAGE_NAME = $$(IMAGE_PREFIX)-$$(if $$(findstring kernel,$$(2)),,$$(1)-)$$(2)
+endef
+TARGET_DEVICES += generic
+
+define Device/ubnt2-pico2
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := XS2-8
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS2-8 -v XS2.ar2316
+endef
+TARGET_DEVICES += ubnt2-pico2
+
+define Device/ubnt2
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := XS2
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS2 -v XS2.ar2316
+endef
+TARGET_DEVICES += ubnt2
+
+define Device/ubnt5
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := XS5
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS5 -v XS5.ar2313
+endef
+TARGET_DEVICES += ubnt5
+
+define Device/np25g
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := NP25G
+ KERNEL := kernel-bin | gzip-kernel
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw np25g
+ BROKEN := y
+endef
+TARGET_DEVICES += np25g
+
+define Device/wpe53g
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPE53G
+ KERNEL := kernel-bin | gzip-kernel
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw wpe53g
+ BROKEN := y
+endef
+TARGET_DEVICES += wpe53g
+
+$(eval $(call BuildImage))