aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-13 19:11:20 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-06 19:49:13 +0200
commitfc920bfb0088250db6bac855f59086abec98b1f1 (patch)
treecc3ee12145985b29b505396b736c76565e3ac839 /target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
parent081e944be6684bf5c4ee7c9fa2683d568d5be288 (diff)
downloadupstream-fc920bfb0088250db6bac855f59086abec98b1f1.tar.gz
upstream-fc920bfb0088250db6bac855f59086abec98b1f1.tar.bz2
upstream-fc920bfb0088250db6bac855f59086abec98b1f1.zip
ath25: refresh patches for kernel 5.4
Refresh patches to make them apply to kernel 5.4. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch')
-rw-r--r--target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch b/target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
index a2b1492250..916e57cb36 100644
--- a/target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
+++ b/target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
@@ -1,22 +1,22 @@
--- a/drivers/net/ethernet/atheros/Makefile
+++ b/drivers/net/ethernet/atheros/Makefile
-@@ -8,3 +8,4 @@ obj-$(CONFIG_ATL2) += atlx/
+@@ -9,3 +9,4 @@ obj-$(CONFIG_ATL2) += atlx/
obj-$(CONFIG_ATL1E) += atl1e/
obj-$(CONFIG_ATL1C) += atl1c/
obj-$(CONFIG_ALX) += alx/
+obj-$(CONFIG_NET_AR231X) += ar231x/
--- a/drivers/net/ethernet/atheros/Kconfig
+++ b/drivers/net/ethernet/atheros/Kconfig
-@@ -5,7 +5,7 @@
+@@ -6,7 +6,7 @@
config NET_VENDOR_ATHEROS
bool "Atheros devices"
default y
-- depends on PCI
-+ depends on (PCI || ATH25)
+- depends on (PCI || ATH79)
++ depends on (PCI || ATH25 || ATH79)
---help---
If you have a network (Ethernet) card belonging to this class, say Y.
-@@ -78,4 +78,10 @@ config ALX
+@@ -87,4 +87,10 @@ config ALX
To compile this driver as a module, choose M here. The module
will be called alx.
@@ -1713,7 +1713,7 @@
+
void __init ath25_serial_setup(u32 mapbase, int irq, unsigned int uartclk)
{
- struct uart_port s;
+ #ifdef CONFIG_SERIAL_8250_CONSOLE
--- a/arch/mips/include/asm/mach-ath25/ath25_platform.h
+++ b/arch/mips/include/asm/mach-ath25/ath25_platform.h
@@ -71,4 +71,15 @@ struct ar231x_board_config {