aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2019-11-28 12:53:01 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 15:28:03 +0100
commit6aaa5ce2c5138877e0f0504c3bd536b40e9af928 (patch)
tree1e6407da8bf1d4cfce5d4ca59cc6dcdb6497b879 /target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts
parent26c25567751646f2ac45c389019a08e37170da73 (diff)
downloadupstream-6aaa5ce2c5138877e0f0504c3bd536b40e9af928.tar.gz
upstream-6aaa5ce2c5138877e0f0504c3bd536b40e9af928.tar.bz2
upstream-6aaa5ce2c5138877e0f0504c3bd536b40e9af928.zip
ath79: add support for MikroTik RouterBOARD wAP G-5HacT2HnD
This commit adds support for the MikroTik RouterBOARD wAP G-5HacT2HnD (wAP AC), a small weatherproof dual band, dual-radio 802.11ac wireless AP with integrated omnidirectional anntennae and one 10/100/1000 Mbps Ethernet port. See https://mikrotik.com/product/RBwAPG-5HacT2HnD for more info. Specifications: - SoC: Qualcomm Atheros QCA9556 - RAM: 64 MB - Storage: 16 MB NOR - Wireless: · Atheros AR9550 (SoC) 802.11b/g/n 2x2:2, 2 dBi antennae · Qualcomm QCA9880 802.11a/n/ac 3x3:3, 2 dBi antennae - Ethernet: Atheros AG71xx (SoC, AR8033), 1x 1000/100/10 port, passive PoE in Working: - Board/system detection - Sysupgrade - Serial console - Ethernet - 2.4 GHz radio - 5 GHz radio and LED - Reset button Not working/Unsupported: - 2.4 GHz LED - AP/CAP LED - ZT2046Q SPI temperature and voltage sensor This adds the basic features for supporting MikroTik devices: - a common recipe for mikrotik images in common-mikrotik.mk - support for minor (MikroTik NOR) split firmware (only for generic subtarget so far) Acknowledgments: Robert Marko <robimarko@gmail.com> Andrew Cameron <apcameron@softhome.net> Koen Vandeputte <koen.vandeputte@ncentric.com> Chuanhong Guo <gch981213@gmail.com> Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> Co-developed-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts')
-rw-r--r--target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts138
1 files changed, 138 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts b/target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts
new file mode 100644
index 0000000000..e13b58b600
--- /dev/null
+++ b/target/linux/ath79/dts/qca9556_mikrotik_routerboard-wap-g-5hact2hnd.dts
@@ -0,0 +1,138 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+ compatible = "mikrotik,routerboard-wap-g-5hact2hnd", "qca,qca9556";
+ model = "MikroTik RouterBOARD wAP G-5HacT2HnD";
+
+ aliases {
+ label-mac-device = &eth1;
+ mdio-gpio1 = &mdio2;
+ serial0 = &uart;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ mdio2: mdio {
+ compatible = "virtual,mdio-gpio";
+
+ gpios = <&gpio 12 GPIO_ACTIVE_HIGH>, /* MDC */
+ <&gpio 11 GPIO_ACTIVE_HIGH>; /* MDIO */
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ device_type = "ethernet-phy";
+
+ phy-mode = "sgmii";
+
+ at803x-override-sgmii-link-check;
+ };
+ };
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&art 0x10>;
+
+ pll-data = <0x03000101 0x80000101 0x80001313>;
+ phy-handle = <&phy0>;
+
+ qca955x-sgmii-fixup;
+
+ gmac-config {
+ device = <&gmac>;
+ };
+};
+
+&spi {
+ status = "okay";
+
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <104000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "routerboot";
+ reg = <0x000000 0x00e000>;
+ read-only;
+ };
+
+ art: partition@e000 {
+ label = "art";
+ reg = <0x000e000 0x001000>;
+ read-only;
+ };
+
+ partition@f000 {
+ label = "bios";
+ reg = <0x000f000 0x001000>;
+ read-only;
+ };
+
+ partition@10000 {
+ label = "routerboot2";
+ reg = <0x010000 0x00f000>;
+ read-only;
+ };
+
+ partition@1f000 {
+ label = "soft_config";
+ reg = <0x001f000 0x001000>;
+ };
+
+ partition@20000 {
+ compatible = "mikrotik,minor";
+ label = "firmware";
+ reg = <0x020000 0xfe0000>;
+ };
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ qca,no-eeprom;
+};
+
+&pcie0 {
+ status = "okay";
+
+ wifi@0,0 {
+ compatible = "qcom,ath10k";
+ reg = <0 0 0 0 0>;
+ };
+};