aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/qca9563_phicomm-k2t.dts
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/qca9563_phicomm-k2t.dts
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/qca9563_phicomm-k2t.dts')
-rw-r--r--target/linux/ath79/dts/qca9563_phicomm-k2t.dts151
1 files changed, 0 insertions, 151 deletions
diff --git a/target/linux/ath79/dts/qca9563_phicomm-k2t.dts b/target/linux/ath79/dts/qca9563_phicomm-k2t.dts
deleted file mode 100644
index 4ff9320d5c..0000000000
--- a/target/linux/ath79/dts/qca9563_phicomm-k2t.dts
+++ /dev/null
@@ -1,151 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
-
-/ {
- model = "Phicomm K2T";
- compatible = "phicomm,k2t";
-
- aliases {
- led-status = &status_red;
- };
-
- chosen {
- bootargs = "console=ttyS0,115200n8";
- };
-
- leds {
- compatible = "gpio-leds";
-
- status_blue {
- label = "phicomm:blue:status";
- gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- status_red: status_red {
- label = "phicomm:red:status";
- gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
- default-state = "off";
- };
-
- status_yellow {
- label = "phicomm:yellow:status";
- gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
- };
-
- keys {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset {
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&pcie {
- status = "okay";
-};
-
-&spi {
- num-cs = <1>;
-
- status = "okay";
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x000000 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "config";
- reg = <0x030000 0x10000>;
- read-only;
- };
-
- partition@40000 {
- label = "permanent";
- reg = <0x040000 0x50000>;
- read-only;
- };
-
- partition@90000 {
- label = "firmware";
- reg = <0x090000 0xf60000>;
- };
-
- art: partition@ff0000 {
- label = "art";
- reg = <0xff0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-&mdio0 {
- status = "okay";
-
- phy-mask = <0>;
-
- phy0: ethernet-phy@0 {
- reg = <0>;
- phy-mode = "sgmii";
-
- qca,ar8327-initvals = <
- 0x04 0x00080080 /* PORT0 PAD MODE CTRL */
- 0x10 0x81000080 /* POWER_ON_STRIP */
- 0x50 0xcc35cc35 /* LED_CTRL0 */
- 0x54 0xcb37cb37 /* LED_CTRL1 */
- 0x58 0x00000000 /* LED_CTRL2 */
- 0x5c 0x00f3cf00 /* LED_CTRL3 */
- 0x7c 0x0000007e /* PORT0_STATUS */
- >;
- };
-};
-
-&eth0 {
- status = "okay";
-
- pll-data = <0x03000101 0x00000101 0x00001919>;
-
- phy-mode = "sgmii";
- phy-handle = <&phy0>;
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
-};