aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-07-17 17:09:14 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 10:43:33 +0200
commit7ae9e6371936c01b28ea413cca3e69e5a6979386 (patch)
tree2cfcc889e8a4bc5526777ccbfb961963e223fa4b /target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
parent83d2dbc59924c90dd865de113a55d60826ac0c04 (diff)
downloadupstream-7ae9e6371936c01b28ea413cca3e69e5a6979386.tar.gz
upstream-7ae9e6371936c01b28ea413cca3e69e5a6979386.tar.bz2
upstream-7ae9e6371936c01b28ea413cca3e69e5a6979386.zip
ath79: ag71xx: Make builtin switch driver a separated module
This patch did several things: 1. Probe the builtin switch as a separated mdio device. 2. Register a separated mdio bus for builtin switch. 3. Use generic mdio read/write function instead of calling ag71xx_mdio_mii_read/write directly. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile')
-rw-r--r--target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile b/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
index 3636077166..480dbb62c0 100644
--- a/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
+++ b/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
@@ -6,10 +6,9 @@ ag71xx-y += ag71xx_main.o
ag71xx-y += ag71xx_gmac.o
ag71xx-y += ag71xx_ethtool.o
ag71xx-y += ag71xx_phy.o
-ag71xx-y += ag71xx_ar7240.o
ag71xx-$(CONFIG_AG71XX_DEBUG_FS) += ag71xx_debugfs.o
+obj-$(CONFIG_AG71XX) += ag71xx_ar7240.o
obj-$(CONFIG_AG71XX) += ag71xx_mdio.o
obj-$(CONFIG_AG71XX) += ag71xx.o
-