aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorPeter Lundkvist <peter.lundkvist@gmail.com>2018-06-29 05:44:58 +0200
committerJohn Crispin <john@phrozen.org>2018-07-02 07:05:33 +0200
commit781ad46206ddaee74e40d7dbc68840fae1c0cc7c (patch)
treeca8ec054dcd0fac6531bdb74dda5316267ecce96 /target/linux/ath79/image/generic-tp-link.mk
parentf4ac88b5097685950c6f6ba0077840f85446389f (diff)
downloadupstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.tar.gz
upstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.tar.bz2
upstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.zip
ath79: add support for TP-Link RE450 v2
TP-Link RE450 v2 is a dual band router/range-extender based on Qualcomm/Atheros QCA9563 + QCA9880. Specification: - 775 MHz CPU - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 3T3R 5 GHz - 1x 10/100/1000 Mbps Ethernet (AR8033 PHY) - 7x LED, 4x button - UART header on PCB (needs unmounted R64 & R69 0201 resistors/jumpers) Flash instruction: Apply factory image in OEM firmware web-gui. U-Boot does not seem to have any recovery functions, so debricking requires connection via UART. Signed-off-by: Peter Lundkvist <peter.lundkvist@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 28fac6a631..537dafa152 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -13,6 +13,24 @@ define Device/tl-archer-c7-v2
endef
TARGET_DEVICES += tl-archer-c7-v2
+define Device/tl-re450-v2
+ $(Device/tplink)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 6016k
+ DEVICE_TITLE := TP-LINK RE450 v2
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ TPLINK_BOARD_ID := RE450-V2
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+ SUPPORTED_DEVICES := tplink,re450-v2
+endef
+TARGET_DEVICES += tl-re450-v2
+
define Device/tl-wdr3600
$(Device/tplink-8mlzma)
ATH_SOC := ar9344