aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-08-19 15:10:04 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2020-09-28 01:28:37 +0200
commitb33ce8c5355eec61663ce0ac789118f82041045f (patch)
tree7b6b797569a90384aa6a5a1accff586234059199 /target/linux/ath79/image/generic.mk
parenta2f3a586073a0d3bc3a3e16fcd67ca099cf00eab (diff)
downloadupstream-b33ce8c5355eec61663ce0ac789118f82041045f.tar.gz
upstream-b33ce8c5355eec61663ce0ac789118f82041045f.tar.bz2
upstream-b33ce8c5355eec61663ce0ac789118f82041045f.zip
ath79: add support for Hak5 Packet Squirrel
Hak5 Packet Squirrel is a pocket-sized device dedicated for pentesters (MITM attacks). This device is based on Atheros AR9331 but it lacks WiFi. Support for it was first introduced in 950b278c81 (ar71xx). Specifications: - Atheros AR9331 - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of flash (SPI NOR) - 2x RJ45 10/100 Mbps Ethernet (AR9331) - 1x USB 2.0 - 1x RGB LED, 1x button, 1x 4-way mechanical switch - 1x Micro USB Type-B for main power input Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on OpenWrt/LEDE. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 25d0f5b8ba..a5f282be9b 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1032,6 +1032,19 @@ define Device/hak5_lan-turtle
endef
TARGET_DEVICES += hak5_lan-turtle
+define Device/hak5_packet-squirrel
+ $(Device/tplink-16mlzma)
+ SOC := ar9331
+ DEVICE_VENDOR := Hak5
+ DEVICE_MODEL := Packet Squirrel
+ TPLINK_HWID := 0x5351524c
+ IMAGES := sysupgrade.bin
+ DEVICE_PACKAGES := kmod-usb-chipidea2 -iwinfo -kmod-ath9k -swconfig \
+ -uboot-envtools -wpad-basic-wolfssl
+ SUPPORTED_DEVICES += packet-squirrel
+endef
+TARGET_DEVICES += hak5_packet-squirrel
+
define Device/iodata_etg3-r
SOC := ar9342
DEVICE_VENDOR := I-O DATA