aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorJun Su <howard0su@gmail.com>2020-03-03 17:33:40 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 13:53:12 +0100
commitb9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b (patch)
treef767968a29603ea47f23a85c4805f33e84b45112 /target/linux/ath79/image/tiny-tp-link.mk
parent5c2b130ec9b011691771cad2dab9994a66836a1a (diff)
downloadupstream-b9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b.tar.gz
upstream-b9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b.tar.bz2
upstream-b9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b.zip
ath79: add support for TP-Link TL-WR740N v5
This adds support for the TP-Link TL-WR740N v5, a clone of the v4 only with a different TPLINK_HWID. It was already supported in ar71xx as well. Specifications: SOC: Atheros AR9331 CPU: 400MHz Flash: 4 MiB RAM: 32 MiB WLAN: Atheros AR9330 bgn Ethernet: 5 ports (100M) Flashing instructions: - Flash factory image from OEM WebUI: openwrt-ath79-tiny-tplink_tl-wr740n-v5-squashfs-factory.bin - Sysupgrade from ar71xx image: openwrt-ath79-tiny-tplink_tl-wr740n-v5-squashfs-sysupgrade.bin Signed-off-by: Jun Su <howard0su@gmail.com> [commit title/message facelift] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 29fdfec1e5..dc91a74ae1 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -186,6 +186,15 @@ define Device/tplink_tl-wr740n-v4
endef
TARGET_DEVICES += tplink_tl-wr740n-v4
+define Device/tplink_tl-wr740n-v5
+ $(Device/tplink-4mlzma)
+ SOC := ar9331
+ DEVICE_MODEL := TL-WR740N
+ DEVICE_VARIANT := v5
+ TPLINK_HWID := 0x07400005
+endef
+TARGET_DEVICES += tplink_tl-wr740n-v5
+
define Device/tplink_tl-wr741-v1
$(Device/tplink-4m)
SOC := ar7240