aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2021-01-01 16:48:52 -0500
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-07 19:51:50 +0100
commit0070650df45da29a55a89922544dba6859c18f2b (patch)
tree8d39fecdb7add794f134e586b85427a059f3265f /target/linux/ath79/image/tiny.mk
parentecded5bf0908953c47933967c0046cceb3ce0ec1 (diff)
downloadupstream-0070650df45da29a55a89922544dba6859c18f2b.tar.gz
upstream-0070650df45da29a55a89922544dba6859c18f2b.tar.bz2
upstream-0070650df45da29a55a89922544dba6859c18f2b.zip
ath79: move small-flash Engenius boards to tiny
This moves some of the Engenius boards from generic to tiny: - EAP350 v1 - ECB350 v1 - ENH202 v1 For these, factory.bin builds are already failing on master branch because of the unique situation for these boards: - 8 MB flash - an extra "failsafe" image for recovery - TFTP does not work (barely possible with 600 MTU) - bootloader loads image from a longer flash offset - 1 eraseblock each needed for OKLI kernel loader and fake rootfs - using mtd-concat to make use of remaining space... The manual alternative would be removing the failsafe partition. However this comes with the risk of extremely difficult recovery if a flash ever fails because TFTP on the bootloader is bugged. Signed-off-by: Michael Pratt <mcpratt@pm.me> [improve commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 83c34d718b..36d2818ad5 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -1,4 +1,5 @@
include ./common-buffalo.mk
+include ./common-engenius.mk
define Device/buffalo_whr-g301n
$(Device/buffalo_common)
@@ -30,6 +31,40 @@ define Device/dlink_dir-615-e4
endef
TARGET_DEVICES += dlink_dir-615-e4
+define Device/engenius_eap350-v1
+ $(Device/engenius_loader_okli)
+ SOC := ar7242
+ DEVICE_MODEL := EAP350
+ DEVICE_VARIANT := v1
+ IMAGE_SIZE := 4864k
+ LOADER_FLASH_OFFS := 0x1b0000
+ ENGENIUS_IMGNAME := senao-eap350
+endef
+TARGET_DEVICES += engenius_eap350-v1
+
+define Device/engenius_ecb350-v1
+ $(Device/engenius_loader_okli)
+ SOC := ar7242
+ DEVICE_MODEL := ECB350
+ DEVICE_VARIANT := v1
+ IMAGE_SIZE := 4864k
+ LOADER_FLASH_OFFS := 0x1b0000
+ ENGENIUS_IMGNAME := senao-ecb350
+endef
+TARGET_DEVICES += engenius_ecb350-v1
+
+define Device/engenius_enh202-v1
+ $(Device/engenius_loader_okli)
+ SOC := ar7240
+ DEVICE_MODEL := ENH202
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := rssileds
+ IMAGE_SIZE := 4864k
+ LOADER_FLASH_OFFS := 0x1b0000
+ ENGENIUS_IMGNAME := senao-enh202
+endef
+TARGET_DEVICES += engenius_enh202-v1
+
define Device/pqi_air-pen
SOC := ar9330
DEVICE_VENDOR := PQI