aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-09 15:00:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-26 19:14:15 +0100
commit385f4868bc58b04e465db2fbcfce848a75009a74 (patch)
treeaa1f7b3393275121c78f816fd713ec19bd8641a7 /target/linux/ath79/image
parent676ca94c3ca5421c7176d67a211fa29b1bb2e219 (diff)
downloadupstream-385f4868bc58b04e465db2fbcfce848a75009a74.tar.gz
upstream-385f4868bc58b04e465db2fbcfce848a75009a74.tar.bz2
upstream-385f4868bc58b04e465db2fbcfce848a75009a74.zip
ath79: add support for TP-Link TL-WA860RE v1
This ports support for the TL-WA860RE v1 range extender from ar71xx to ath79. Specifications: Board: AP123 / AR9341 rev. 3 Flash/RAM: 4/32 MiB CPU: 535 MHz WiFi: 2.4 GHz b/g/n Ethernet: 1 port (100M) Two external antennas Flashing instructions: Upload the factory image via the vendor firmware upgrade option. Recovery: Note that this device does not provide TFTP via ethernet like many other TP-Link devices do. You will have to open the case if you require recovery beyond failsafe. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Sebastian Knapp <sebastian4842@outlook.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index dc91a74ae1..c533de3f4c 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -130,6 +130,16 @@ define Device/tplink_tl-wa850re-v2
endef
TARGET_DEVICES += tplink_tl-wa850re-v2
+define Device/tplink_tl-wa860re-v1
+ $(Device/tplink-4mlzma)
+ SOC := ar9341
+ DEVICE_MODEL := TL-WA860RE
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x08600001
+ SUPPORTED_DEVICES += tl-wa860re
+endef
+TARGET_DEVICES += tplink_tl-wa860re-v1
+
define Device/tplink_tl-wa901nd-v1
$(Device/tplink-4m)
SOC := ar7240