aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorBernhard Frauendienst <openwrt@nospam.obeliks.de>2018-08-18 18:28:02 +0200
committerJohn Crispin <john@phrozen.org>2018-09-10 09:35:07 +0200
commit480bf28273926d7b30be21b7605dd4fefd07fc3a (patch)
tree179f81612e218aa63447945c8b8eaedb6d75b3cb /target/linux/ath79/image
parent3370e104954191eeab97df7cd07146d7c48e180d (diff)
downloadupstream-480bf28273926d7b30be21b7605dd4fefd07fc3a.tar.gz
upstream-480bf28273926d7b30be21b7605dd4fefd07fc3a.tar.bz2
upstream-480bf28273926d7b30be21b7605dd4fefd07fc3a.zip
ath79: add support for Buffalo WZR-HP-AG300H
Buffalo WZR-HP-AG300H is a dual band router based on Qualcom Atheros AR7161 rev 2 Specification: - 680 MHz CPU (Qualcomm Atheros AR7161) - 128 MiB RAM (2x Samsung K4H511638G-LCCC) - 32 MiB Flash (2x Winbond 25Q128BVFG) - WiFi 5 GHz a/n (Atheros AR9220) - WiFi 2.4 GHz b/g/n (Atheros AR9223) - 1000Base-T WAN (Atheros AR7161) - 4x 1000Base-T Switch (Atheros AR8316) - 1x USB 2.0 - 3 Buttons (AOSS/WPS, Reset, USB Eject) - 2 Slide switches (Router (on/off/auto), Movie Engine (on/off)) - 9 LEDs (Power green, WLAN 2GHz green, WLAN 2GHz amber, WLAN 5GHz green, WLAN 5GHz LED amber, Router green, Diag red, Movie Engine blue, USB green) It is already supported by the ar71xx target. For more information on the device visit the wiki: <https://openwrt.org/toh/buffalo/wzr-hp-ag300h> Serial console: - The UART Header is next to Movie Engine Switch. - Pinout is RX - TX - GND - 3.3V (Square Pad is 3.3V) - The Serial setting is 115200-8-N-1. Installation of OpenWRT from vendor firmware: - Connect to the Web-interface at http://192.168.11.1 - Go to “Administration” → “Firmware Upgrade” - Upload the OpenWrt factory image Tested: - Ethernet (LAN, WAN) - WiFi - Installation - via TFTP rescue - via factory image - on firmware v1.77 (28-05-2012) - on pro firmware v24SP2 r30356 (26-03-2018) - via sysupgrade from ar71xx (wlan devices don't work because of new names) - via sysupgrade from itself - Buttons - LEDS - USB (Power control and device recognition) Signed-off-by: Bernhard Frauendienst <openwrt@nospam.obeliks.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/common-buffalo.mk20
-rw-r--r--target/linux/ath79/image/generic.mk14
-rw-r--r--target/linux/ath79/image/tiny.mk21
3 files changed, 36 insertions, 19 deletions
diff --git a/target/linux/ath79/image/common-buffalo.mk b/target/linux/ath79/image/common-buffalo.mk
new file mode 100644
index 0000000000..a756f8448b
--- /dev/null
+++ b/target/linux/ath79/image/common-buffalo.mk
@@ -0,0 +1,20 @@
+define Build/buffalo-tftp-header
+ ( \
+ echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
+define Build/buffalo-tag
+ $(eval product=$(word 1,$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-tag \
+ -c 0x80041000 -d 0x801e8000 -w 3 \
+ -a ath -v 1.99 -m 1.01 -f 1 \
+ -b $(product) -p $(product) \
+ -r M_ -l mlang8 \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
+
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fc38c09958..e968dcf92c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1,3 +1,4 @@
+include ./common-buffalo.mk
include ./common-netgear.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
@@ -68,6 +69,19 @@ define Device/avm_fritz4020
endef
TARGET_DEVICES += avm_fritz4020
+define Device/buffalo_wzr-hp-ag300h
+ ATH_SOC := ar7161
+ DEVICE_TITLE := Buffalo WZR-HP-AG300H
+ IMAGE_SIZE := 32256k
+ IMAGES += factory.bin tftp.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-AG300H 1.99 | buffalo-tag WZR-HP-AG300H
+ IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport kmod-leds-reset kmod-owl-loader
+ SUPPORTED_DEVICES += wzr-hp-ag300h
+endef
+TARGET_DEVICES += buffalo_wzr-hp-ag300h
+
define Device/buffalo_wzr-hp-g450h
ATH_SOC := ar7242
DEVICE_TITLE := Buffalo WZR-HP-G450H
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 0047554620..531a7f30c2 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -1,23 +1,6 @@
-DEVICE_VARS += ROOTFS_SIZE
-
-define Build/buffalo-tftp-header
- ( \
- echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
- dd if=$@; \
- ) > $@.new
- mv $@.new $@
-endef
+include ./common-buffalo.mk
-define Build/buffalo-tag
- $(eval product=$(word 1,$(1)))
- $(STAGING_DIR_HOST)/bin/buffalo-tag \
- -c 0x80041000 -d 0x801e8000 -w 3 \
- -a ath -v 1.99 -m 1.01 -f 1 \
- -b $(product) -p $(product) \
- -r M_ -l mlang8 \
- -i $@ -o $@.new
- mv $@.new $@
-endef
+DEVICE_VARS += ROOTFS_SIZE
define Device/buffalo_bhr-4grv2
ATH_SOC := qca9558