aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-07-07 18:04:37 +0200
committerPetr Štetiar <ynezz@true.cz>2020-11-23 22:53:15 +0100
commit4f86edf477edbc0f20b5a49a69f658fa82158284 (patch)
tree25df384d5b1c5c3e2eaf4de8c3fc8060d3d11274 /target/linux/ath79/image
parentb11ad48764404d6eefc01b5acf9e54c9f6f00973 (diff)
downloadupstream-4f86edf477edbc0f20b5a49a69f658fa82158284.tar.gz
upstream-4f86edf477edbc0f20b5a49a69f658fa82158284.tar.bz2
upstream-4f86edf477edbc0f20b5a49a69f658fa82158284.zip
ath79: support for TP-Link EAP225-Outdoor v1
TP-Link EAP225-Outdoor v1 is an AC1200 (802.11ac Wave-2) pole or wall mount access point. Debricking requires access to the serial port, which is non-trivial. Device specifications: * SoC: QCA9563 @ 775MHz * Memory: 128MiB DDR2 * Flash: 16MiB SPI-NOR * Wireless 2.4GHz (SoC): b/g/n 2x2 * Wireless 5GHz (QCA9886): a/n/ac 2x2 MU-MIMO * Ethernet (AR8033): 1× 1GbE, PoE Flashing instructions: * ssh into target device with recent (>= v1.6.0) firmware * run `cliclientd stopcs` on target device * upload factory image via web interface Debricking: To recover the device, you need access to the serial port. This requires fine soldering to test points, or the use of probe pins. * Open the case and solder wires to the test points: RXD, TXD and TPGND4 * Use a 3.3V UART, 115200 baud, 8n1 * Interrupt bootloader by holding ctrl+B during boot * upload initramfs via built-in tftp client and perform sysupgrade setenv ipaddr 192.168.1.1 # default, change as required setenv serverip 192.168.1.10 # default, change as required tftp 0x80800000 initramfs.bin bootelf $fileaddr MAC addresses: MAC address (as on device label) is stored in device info partition at an offset of 8 bytes. ath9k device has same address as ethernet, ath10k uses address incremented by 1. From stock ifconfig: ath0 Link encap:Ethernet HWaddr D8:...:2E ath10 Link encap:Ethernet HWaddr D8:...:2F br0 Link encap:Ethernet HWaddr D8:...:2E eth0 Link encap:Ethernet HWaddr D8:...:2E Tested by forum user PolynomialDivision on firmware v1.7.0. UART access tested by forum user arinc9. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index c704d99c98..343ea963c3 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -371,6 +371,17 @@ define Device/tplink-eap2x5
pad-extra 128
endef
+define Device/tplink_eap225-outdoor-v1
+ $(Device/tplink-eap2x5)
+ SOC := qca9563
+ IMAGE_SIZE := 13824k
+ DEVICE_MODEL := EAP225-Outdoor
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ TPLINK_BOARD_ID := EAP225-OUTDOOR-V1
+endef
+TARGET_DEVICES += tplink_eap225-outdoor-v1
+
define Device/tplink_eap225-wall-v2
$(Device/tplink-eap2x5)
SOC := qca9561