aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-30 23:32:07 +0100
commit80713657b20d58c2fb7fa503e24cbf7db379550f (patch)
tree9c32cb3932f60c063e84630c1818c92d204b405e /target/linux/ath79/image
parentff9e48e75c191e0d7e08a14791853559d509ca2e (diff)
downloadupstream-80713657b20d58c2fb7fa503e24cbf7db379550f.tar.gz
upstream-80713657b20d58c2fb7fa503e24cbf7db379550f.tar.bz2
upstream-80713657b20d58c2fb7fa503e24cbf7db379550f.zip
ath79: Add support for OpenMesh OM5P
Device specifications: ====================== * Qualcomm/Atheros AR9344 rev 2 * 560/450/225 MHz (CPU/DDR/AHB) * 64 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 2x 10/100 Mbps Ethernet * 2T2R 5 GHz Wi-Fi * 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x fast ethernet - eth0 + builtin switch port 1 + used as LAN interface - eth1 + 18-24V passive POE (mode B) + used as WAN interface * 12-24V 1A DC * internal antennas WAN/LAN LEDs appear to be wrong in ar71xx and have been swapped here. Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org> [add LED swap comment] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index acb456ba44..ded8e29c2c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1630,6 +1630,25 @@ define Device/openmesh_om2p-lc
endef
TARGET_DEVICES += openmesh_om2p-lc
+define Device/openmesh_om5p-common
+ SOC := ar9344
+ DEVICE_VENDOR := OpenMesh
+ DEVICE_PACKAGES := uboot-envtools
+ IMAGE_SIZE := 7808k
+ BLOCKSIZE := 64k
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
+ pad-to $$(BLOCKSIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
+ openmesh-image ce_type=OM5P | append-metadata
+endef
+
+define Device/openmesh_om5p
+ $(Device/openmesh_om5p-common)
+ DEVICE_MODEL := OM5P
+ SUPPORTED_DEVICES += om5p
+endef
+TARGET_DEVICES += openmesh_om5p
+
define Device/openmesh_om5p-ac-v2
SOC := qca9558
DEVICE_VENDOR := OpenMesh