aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-08-19 14:20:54 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2020-09-28 01:28:37 +0200
commita2f3a586073a0d3bc3a3e16fcd67ca099cf00eab (patch)
treea1f842eee5a8d1e3691c07d28079697ddbaf8091 /target/linux/ath79/image
parentb4e9e81002763127cad633d2886678b6137a8768 (diff)
downloadupstream-a2f3a586073a0d3bc3a3e16fcd67ca099cf00eab.tar.gz
upstream-a2f3a586073a0d3bc3a3e16fcd67ca099cf00eab.tar.bz2
upstream-a2f3a586073a0d3bc3a3e16fcd67ca099cf00eab.zip
ath79: add support for Hak5 LAN Turtle
Hak5 LAN Turtle is an "USB Ethernet Adapter" shaped device dedicated for sysadmins and pentesters. This device is based on Atheros AR9331 but it lacks WiFi. Support for it was first introduced in 950b278c81 (ar71xx). Two different versions of this device exist and it's up to the user to install required drivers (generic image supports only common features): - LAN Turtle 3G with Quectel UG96 3G modem - LAN Turtle SD with microSD card reader (Alcorlink AU6435R) Specifications: - Atheros AR9331 - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of flash (SPI NOR) - 1x RJ45 10/100 Mbps Ethernet (AR9331) - 1x USB 2.0 to 10/100 Ethernet bridge (Realtek RTL8152B) - 2x LED (power, system), 1x button (inside, on the PCB) - USB 2.0 Type-A plug for power and RTL8152B Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on OpenWrt/LEDE. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b5af99971d..25d0f5b8ba 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1019,6 +1019,19 @@ define Device/glinet_gl-x750
endef
TARGET_DEVICES += glinet_gl-x750
+define Device/hak5_lan-turtle
+ $(Device/tplink-16mlzma)
+ SOC := ar9331
+ DEVICE_VENDOR := Hak5
+ DEVICE_MODEL := LAN Turtle
+ TPLINK_HWID := 0x5348334c
+ IMAGES := sysupgrade.bin
+ DEVICE_PACKAGES := kmod-usb-chipidea2 -iwinfo -kmod-ath9k -swconfig \
+ -uboot-envtools -wpad-basic-wolfssl
+ SUPPORTED_DEVICES += lan-turtle
+endef
+TARGET_DEVICES += hak5_lan-turtle
+
define Device/iodata_etg3-r
SOC := ar9342
DEVICE_VENDOR := I-O DATA