aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAndreas Wiese <aw-openwrt@meterriblecrew.net>2020-05-27 15:31:30 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-05-31 15:44:05 +0200
commitc764c512ac18ce9724b3fb0e476831150817c162 (patch)
tree1e9d99d246846b38ba5e8ca95160a073ba967c03 /target/linux/ath79/image
parent7e513136c63108bf55b38be4d2b65aa00b0d2b26 (diff)
downloadupstream-c764c512ac18ce9724b3fb0e476831150817c162.tar.gz
upstream-c764c512ac18ce9724b3fb0e476831150817c162.tar.bz2
upstream-c764c512ac18ce9724b3fb0e476831150817c162.zip
ath79: add support for TP-Link RE450 v3
TP-Link RE450 v3 is a dual band router/range-extender based on Qualcomm/Atheros QCA9563 + QCA9880. This device is nearly identical to RE450 v2 besides a modified flash layout (hence I think force-flashing a RE450v2 image will lead to at least loss of MAC address). Specification: - 775 MHz CPU - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 3T3R 5 GHz - 1x 10/100/1000 Mbps Ethernet (AR8033 PHY) - 7x LED, 4x button- - possible UART header on PCB¹ Flash instruction: Apply factory image in OEM firmware web-gui. ¹ Didn't check to connect as I didn't even manage to connect on RE450v2 (AFAIU it requires disconnecting some resistors, which I was too much of a coward to do). But given the similarities to v2 I think it's the same or very similar procedure (and most likely also the only way to debrick). Signed-off-by: Andreas Wiese <aw-openwrt@meterriblecrew.net> [remove dts-v1 and compatible in DTSI] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 3eedce4f8e..5fb36ca621 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -400,6 +400,18 @@ define Device/tplink_re450-v2
endef
TARGET_DEVICES += tplink_re450-v2
+define Device/tplink_re450-v3
+ $(Device/tplink-safeloader)
+ SOC := qca9563
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE450
+ DEVICE_VARIANT := v3
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := RE450-V3
+ LOADER_TYPE := elf
+endef
+TARGET_DEVICES += tplink_re450-v3
+
define Device/tplink_tl-mr6400-v1
$(Device/tplink-8mlzma)
SOC := qca9531