aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-09-04 23:27:01 +0200
committerJohn Crispin <john@phrozen.org>2018-09-10 09:07:11 +0200
commitcd9c2492c18d1c2abd200e5911ad546d7c77a617 (patch)
tree1989635d0b74eec586b3c3a33e8658659af20904 /target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch
parentffa80bf5a784a34b81e32144669f30560780bdb6 (diff)
downloadupstream-cd9c2492c18d1c2abd200e5911ad546d7c77a617.tar.gz
upstream-cd9c2492c18d1c2abd200e5911ad546d7c77a617.tar.bz2
upstream-cd9c2492c18d1c2abd200e5911ad546d7c77a617.zip
ath79: port cybertan_part from ar71xx
This patch ports the cybertan_part code from ar71xx and converts the driver to a DT-supported mtd parser. As a result, it will no longer add the u-boot, nvram and art partitions, which were never part of the special Cybertan header. Instead these partitions have to be specified in the DT, which has the upside of making it possible to add properties (i.e.: read-only), labels and references to these important partitions. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch
new file mode 100644
index 0000000000..2d2a042b04
--- /dev/null
+++ b/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch
@@ -0,0 +1,19 @@
+--- a/drivers/mtd/parsers/Makefile 2018-08-12 02:32:47.951243067 +0200
++++ b/drivers/mtd/parsers/Makefile 2018-08-12 02:33:09.844626814 +0200
+@@ -1 +1,2 @@
++obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
+ obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
+--- a/drivers/mtd/parsers/Kconfig 2018-08-12 02:28:43.987357803 +0200
++++ b/drivers/mtd/parsers/Kconfig 2018-08-12 02:32:23.237852972 +0200
+@@ -1,3 +1,11 @@
++config MTD_PARSER_CYBERTAN
++ tristate "Parser for Cybertan format partitions"
++ depends on MTD && (ATH79 || COMPILE_TEST)
++ help
++ Cybertan has a proprietory header than encompasses a Broadcom trx
++ header. This driver will parse the header and take care of the
++ special offsets that result in the extra headers.
++
+ config MTD_PARSER_TRX
+ tristate "Parser for TRX format partitions"
+ depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)