aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-03-29 08:16:17 +0200
committerRafał Miłecki <rafal@milecki.pl>2021-03-29 08:46:17 +0200
commit3fd0a4222b6efbfbdb560c5b13e899ecda627494 (patch)
tree217011356670c5ce1a87ed2ac5a5106594af99b0 /target/linux/ath79/patches-5.10
parent571aedbc6cbb7a9bfc96bcad543a39d158925cbc (diff)
downloadupstream-3fd0a4222b6efbfbdb560c5b13e899ecda627494.tar.gz
upstream-3fd0a4222b6efbfbdb560c5b13e899ecda627494.tar.bz2
upstream-3fd0a4222b6efbfbdb560c5b13e899ecda627494.zip
kernel: backport 5.13 mtd partitioning changes
1. Use upstream accepted NVMEM patches 2. Minor fix for BCM4908 partitioning 3. Support for Linksys firmware partitions on Northstar Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/ath79/patches-5.10')
-rw-r--r--target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
index 59ee57d277..923589661e 100644
--- a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
+++ b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
@@ -1,18 +1,18 @@
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
-@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myl
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
ofpart-y += ofpart_core.o
ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908) += ofpart_bcm4908.o
+ ofpart-$(CONFIG_MTD_OF_PARTS_LINKSYS_NS)+= ofpart_linksys_ns.o
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
obj-$(CONFIG_MTD_PARSER_IMAGETAG) += parser_imagetag.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
--- a/drivers/mtd/parsers/Kconfig
+++ b/drivers/mtd/parsers/Kconfig
-@@ -92,6 +92,14 @@ config MTD_OF_PARTS_BCM4908
- that can have multiple "firmware" partitions. It takes care of
- finding currently used one and backup ones.
+@@ -102,6 +102,14 @@ config MTD_OF_PARTS_LINKSYS_NS
+ two "firmware" partitions. Currently used firmware has to be detected
+ using CFE environment variable.
+config MTD_PARSER_CYBERTAN
+ tristate "Parser for Cybertan format partitions"