aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-03-01 18:12:48 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-03-01 18:18:38 +0100
commit7a7b2fd809809fbd7045bd3dad4fc896a6fef06f (patch)
treecdb775d788642c833eafdd1ce28a7f4dca22c3c5 /target/linux/ath79/patches-5.10
parentc58005a9431b16107d8c6398b9095a5b3bcfcb25 (diff)
downloadupstream-7a7b2fd809809fbd7045bd3dad4fc896a6fef06f.tar.gz
upstream-7a7b2fd809809fbd7045bd3dad4fc896a6fef06f.tar.bz2
upstream-7a7b2fd809809fbd7045bd3dad4fc896a6fef06f.zip
kernel: add the latest mtd patch extending ofpart parser
This adds the latest version of ofpart commit. It hopefully 1. Doesn't break compilation 2. Doesn't break partitioning (this time). It's required to implement fixed partitioning with some quirks. It's required by bcm53xx, bcm4908, kirkwood, lantiq and mvebu. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/ath79/patches-5.10')
-rw-r--r--target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
index 1ebf87c610..59ee57d277 100644
--- a/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
+++ b/target/linux/ath79/patches-5.10/404-mtd-cybertan-trx-parser.patch
@@ -1,18 +1,18 @@
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
-@@ -5,6 +5,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm6
- obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myl
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ ofpart-y += ofpart_core.o
+ ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908) += ofpart_bcm4908.o
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
obj-$(CONFIG_MTD_PARSER_IMAGETAG) += parser_imagetag.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
--- a/drivers/mtd/parsers/Kconfig
+++ b/drivers/mtd/parsers/Kconfig
-@@ -83,6 +83,14 @@ config MTD_OF_PARTS
- flash memory node, as described in
- Documentation/devicetree/bindings/mtd/partition.txt.
+@@ -92,6 +92,14 @@ config MTD_OF_PARTS_BCM4908
+ that can have multiple "firmware" partitions. It takes care of
+ finding currently used one and backup ones.
+config MTD_PARSER_CYBERTAN
+ tristate "Parser for Cybertan format partitions"