aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.4
diff options
context:
space:
mode:
authorDenis Kalashnikov <denis281089@gmail.com>2021-05-27 11:16:44 +0300
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2021-06-21 10:48:27 +0200
commit7b8931678c36c8d8c333b446258a653b1358bf70 (patch)
treef00022f0d3991f06c1dbb8a9b8c328eb3ae5c3ae /target/linux/ath79/patches-5.4
parentfd0d9909bf50f114d5e7f7cedf53e542de878a2c (diff)
downloadupstream-7b8931678c36c8d8c333b446258a653b1358bf70.tar.gz
upstream-7b8931678c36c8d8c333b446258a653b1358bf70.tar.bz2
upstream-7b8931678c36c8d8c333b446258a653b1358bf70.zip
ath79: add gpio-latch driver for MikroTik RouterBOARDs
This is a slighty modified version of ar71xx gpio-latch driver written by Gabor Juhos <juhosg@openwrt.org>. Changes: * DTS support, * New gpio API (gpiod_*). Reviewed-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> Signed-off-by: Denis Kalashnikov <denis281089@gmail.com>
Diffstat (limited to 'target/linux/ath79/patches-5.4')
-rw-r--r--target/linux/ath79/patches-5.4/939-mikrotik-rb91x.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.4/939-mikrotik-rb91x.patch b/target/linux/ath79/patches-5.4/939-mikrotik-rb91x.patch
new file mode 100644
index 0000000000..baeaab4611
--- /dev/null
+++ b/target/linux/ath79/patches-5.4/939-mikrotik-rb91x.patch
@@ -0,0 +1,23 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -130,6 +130,10 @@ config GPIO_ATH79
+ Select this option to enable GPIO driver for
+ Atheros AR71XX/AR724X/AR913X SoC devices.
+
++config GPIO_LATCH
++ tristate "MikroTik RouterBOARD GPIO latch support"
++ depends on ATH79
++
+ config GPIO_RASPBERRYPI_EXP
+ tristate "Raspberry Pi 3 GPIO Expander"
+ default RASPBERRYPI_FIRMWARE
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_GPIO_IT87) += gpio-it87.o
+ obj-$(CONFIG_GPIO_IXP4XX) += gpio-ixp4xx.o
+ obj-$(CONFIG_GPIO_JANZ_TTL) += gpio-janz-ttl.o
+ obj-$(CONFIG_GPIO_KEMPLD) += gpio-kempld.o
++obj-$(CONFIG_GPIO_LATCH) += gpio-latch.o
+ obj-$(CONFIG_GPIO_LOONGSON1) += gpio-loongson1.o
+ obj-$(CONFIG_GPIO_LOONGSON) += gpio-loongson.o
+ obj-$(CONFIG_GPIO_LP3943) += gpio-lp3943.o